ラベル

Server (108) work (77) Idea (68) Car (31) PC (29) DAW (28) other (19) MakingWEBsite (18) 趣味 (18) health (13) CentOS (11) drupal (11) 山 (9) android (4) スマホ (4) communication (3) drupal7 (3) hint (3) meno (3) モバイル (3) 歯医者 (3) 第二種電気工事士 (3) 英語 (3) PC Server (2) drupal8 (2) ms access (2) uwp C# (2) めし (2) 整備 (2) 音楽 (2) MIDI (1) diy (1) 会計 (1) 動画再生 (1) 生活 (1) 郵便 (1) 食べ物 (1)

2017年5月11日木曜日

CentOS6 Dovecot メールサーバー メールソフト

久しぶりにCentOS上のメールサーバーにWindows10のメールソフト(Becky)からつなごうとしたら、つながらない。

telenetでimap,popのポートを確認するとrefusedとなってしまう。

smtpポートはちゃんと通る。

ポートがふさがっているのかなぁと思って、iptablesとか見てみたけど、ローカルでのメールはふさいでいない。

chkconfig --list dovecot
とすると、ちゃんとオンになっている。(だから動いているはずだと思ったのが間違えだった。)

その後、いろいろな設定をくるくる見回ることになったのだけど、でも、うまくいかず。

で、何気にDovecotのリスタート
service dovecot restart
をかけてみたら、
起動エラー。

要するに、起動してなかったということだった。
で、その時に出たエラー
Starting Dovecot Imap: Error: socket() failed: Address family not supported by protocol
を検索したところ、
「IPv6を無効にしているとDovecot Ver2からは起動に失敗する。」
自分は、今、IPv6を無効にしている。(今はIPv6を無効にしなくてもスムーズに動くようになってきたらしい。)
で、
/etc/dovecot/dovecot.conf
の
#listen = *, ::
を
listen = *
にしたら、普通に起動した。

0 件のコメント:

コメントを投稿