ラベル

Server (108) work (77) Idea (68) Car (31) PC (29) DAW (28) other (19) MakingWEBsite (18) 趣味 (18) health (13) CentOS (11) drupal (11) 山 (9) android (4) スマホ (4) communication (3) drupal7 (3) hint (3) meno (3) モバイル (3) 歯医者 (3) 第二種電気工事士 (3) 英語 (3) PC Server (2) drupal8 (2) ms access (2) uwp C# (2) めし (2) 整備 (2) 音楽 (2) MIDI (1) diy (1) 会計 (1) 動画再生 (1) 生活 (1) 郵便 (1) 食べ物 (1)

2014年2月15日土曜日

停電 Centos mysql トラブル

昨夜(というより早朝かな。)停電した。
けっこう雪が降ったからそれが原因の停電だったのだろう。

で、CentOSサーバーが停止していたんで、朝起動させて
ハードディスクなどが壊れていないのを確認して、
Drupalを表示させようとしたら、「データベースにつながらない」エラーが出て表示できない。

mysqlが動いているのかどうかを確かめるのに
とりあえずストップ、スタートをしてみる。

/etc/rc.d/init.d/mysqld stop
で、止まるけど、
/etc/rc.d/init.d/mysqld start
が失敗する。

おかしいなぁ。
何回かやっても同じ。
ストップして止めて、その後スタートさせるとスタートに失敗するのに、そのスタートが失敗した状態のままストップさせるとコンソール上は正常に止まったということになっている。
これっておかしいだろ。
たぶん動いていないんだろうなぁ。

mysqld.log
を見てみたけど、一ヶ月前のサーバーを再起動したときの記録が最後になっている。
まぁ、停電で突然止まったんだからそうだろうなぁ。

ネットで、mysqlのスタートを失敗したときに表示されたエラーメッセージなどから検索してみると
/var/lib/mysql/mysql.sock が残っているのが原因というのを見つけた。
で、調べてみたら確かにmysql.sockが残っていた。
正常に終了すればこのファイルは削除されるんだろう。

で、削除する。
rm /var/lib/mysql/mysql.sock

mysql.sockを削除したら、普通にmysqlが動き出した。

停電の時はまた同じ現象が起きるだろうからメモしておいた。






0 件のコメント:

コメントを投稿